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1. Basic Object Animation in Flash MX 
 
Flash Tutorial        October 24, 2003 by R. Berdan  
 
Before attempting this tutorial you should have gone through the Help>Lessons 1 and 2 so 
you are familiar with the drawing tools and how to use them.  
 
 

1. Select the circle drawing tool from the tool menu and draw a circle in the upper left part of 
the stage and the fill the circle with a solid color using the paint can 

 
 

2. Select the black pointer from the tool bar, click and drag around the circle you drew on 
the stage. When you finish, the circle will appear to have small tiny dots – this indicates 
you have selected the object. (if you click off or outside of the object you will have to 
reselect it – look for the tiny dots to tell you the object is selected)  

 

 
 

Circle on the left is selected the one on the right is not.  
 
 
3. With the circle still selected Select>Insert>Convert to symbol>Graphic OK. It is optional 

whether or not you want to name the object. You just converted the object into a symbol.  
You must always do this before you can animate an object you draw across the stage. 
The object should now have a blue bounding box around it – this indicates it is a symbol.  

 
4. Select the black pointer from the tool bar and click on the Layer 1 frame box 30 to select 

it – the frame will turn black. Right click on the frame with your mouse and select 
insert>Keyframe. Keyframes are places where an object starts, stops or changes 
direction in a movie.  
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5. Next with the new keyframe you created still selected, click on the circular object and 
move it across the stage to a new location where you want it to stop in the animated 
movie. Then select the first keyframe in layer 1. Select>Insert>Create Motion Tween. 
Layer should have a solid line with an arrow on the end and the layer should turn blue. If 
you see a dotted line you missed a step.  

 

 
  

Note solid blue line in layer 1.  
 
6. To play your movie make sure your controller is displayed Select 

Window>Toolbars>controller – select the play button to start your movie. Your object 
should move across the screen and stop.  

 
 

7. To save your movie select File>save as  provide a name e.g. firstmovie.fla and direct it to 
folder or your desktop.  This movie can be edited and modified at any time by selecting 
File>open. The .fla file is used for editing it does not go into your web site it is like a 
photoshop .psd file – it is for editing only.  

 
 
8. To create a movie that can be inserted into a web page you need to have your .fla file 

open in Flash Select>File>Publish settings>check  Flash .swf checkbox and HTML .html 
check box>Then select Publish>OK  - you just created an HTML page with Flash movie 
embedded.  Embedded Flash movies have the extension .swf sometimes called 
shockwave files – these are compressed versions of the .fla files.  To see your movie 
play click on or load the html file you created into a web browser that has the Flash plugin 
installed.  You should see your movie embedded inside the page and the movie will loop 
continuously.  In spite of years of development, Macromedia has never fixed a small bug 
– that is the movie you embedded will not be centered even though there are publishing 
options to do so – they have never worked. To center your movie select >View source 
when previewing it in Internet explorer and add the <center></center> tags manually as 
shown below.  Alternatively you can open the page in Dreamweaver and use the center 
align commands, you can insert the movie into other pages using copy paste of the code 
or you can use Dreamweaver to insert the .swf files – the .swf files must be in the same 
place your web pages are! 

 
<center> 
<OBJECT classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" 
codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version
=6,0,0,0" 
 WIDTH="550" HEIGHT="400" id="Untitled-2" ALIGN=""> 
 <PARAM NAME=movie VALUE="Untitled-2.swf"> <PARAM NAME=quality VALUE=high> 
<PARAM NAME=bgcolor VALUE=#FFFFFF> <EMBED src="Untitled-2.swf" quality=high 
bgcolor=#FFFFFF  WIDTH="550" HEIGHT="400" NAME="Untitled-2" ALIGN="" 
 TYPE="application/x-shockwave-flash" 
PLUGINSPAGE="http://www.macromedia.com/go/getflashplayer"></EMBED> 
</OBJECT> 
</center>  
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9. To have the animation play only once you must add an action to the last keyframe. 
Actions are small scripts that provide instructions such as stop, jump to frame, play, 
rewind etc. adding actionscript  is one way to add interanctivity to your flash movie. To 
add a stop action to the movie we created you will need to select the black pointer>Select 
the last keyframe in the movie right click> on the pop down menu select actions.  

 

 
 
 

10. To insert an action you can do it two way 1) In the main window type stop();     or 2) Click on 
the movie control folder on the left side of the window it will open to reveal different actions.  
Double click or drag the stop action into the main window  - then close it.  You will see a small “a” 
in the last keyframe – this tells the movie to stop when it reaches this point.  Save your movie – 
then publish it again.  If you unselect the HTML checkbox you will not overwrite the HTML page 
only the .swf file  - if you do overwrite the HTML file you will simply need to add the 
<center></center> tags again. You are done! 
 

10. One other option you might want to know about is that you can save .fla files as .exe files 
– movies that will play bythemselves without embedding inside an HTML page.  These 
type of movies are used in multimedia presentations, games, business card CDs. They 
are standalone programs that you can e-mail or take with you. To publish a standalone 
Flash movie make sure your previous movie is open select >File>Publish settings>format 
tab should be selected select>Windows projector or Macintosch projector if you want 
your movie to play standalone on a Mac computer. Select Publish>OK and you will see a 
new icon where you saved your files – click on the icon to start your stand alone movie 
program.  
 

  The top icon is a  .swf file and the bottom icon shows a stand alone .exe file.  
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A. Exercise and practice. Make your circle go completely around the stage so it goes to 
each corner. To do this you will need to add additional keyframes and motion tween 
between each one.  The distance between keyframes determines how fast your object 
moves – keyframes close together will result in faster animation, further apart will result in 
slower animations.  

 
 
2. Motion along a specified Path 

 
You can use the animation you created in the previous tutorial or you can start from scratch 
with a new object – either way you must have a moving object to start this tutorial. We are 
going to add a new layer called a motion layer, then we will draw a smooth line that does not 
overlap to simulate a bouncing ball. We will attach the ball or object to the line at the 
beginning and ending keygrame and play our movie – it you do this correctly the ball will 
bounce. It can be a bit tricky attaching the object to the line so persevere.  
 
 
1. Right click your mouse pointer on Layer one> In the pop down menu select Motion Guide 

layer then click on this layer to select it. Only the motion guide layer should be selected. 
 

2. Select the pencil tool and the bottom of the tool box select Option>smooth from the pop 
out menu. Draw a line resembling the bounce path of a ball – see picture below.  
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3. The object (circle) may jump and attach itself to the line – if it does great, if it does not 
drag the object by its center over the beginning of the line until it snaps in place. If it does 
not snap in place make sure the magnet button at the top is depressed (i.e. turned on – 
this is the snap tool). Then select the last key frame of the movie with the black arrow you 
should see something like the picture below.  

 

 
 
 

4. Move the circle with your mouse (black arrowhead selected in the toolbar) until it snaps to 
the line near the end of your drawing.  Go to the controller (below) and play your movie. 

 

 
 

 
The ball should follow the line and appear to bounce. Make sure the lines you draw do not 
touch each other or cross over each other – it will not work. Save and publish your movie.  
The lines you drew will not appear in the final movie, however the object will appear to follow 
them.  
 
Exercise: You can import small images e.g. .jpg and .gif files, convert them to symbols just 
as you did with the object you created then animate them in your window.  Try this with a 
small picture of a plane, clock or some other image you have.  
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3. Shape Tweening also called Morphing  
 
Using flash it is possible to create objects then animate them by morphing one object into 
another.  Generally this works well only with simple objects because Flash has to do all the 
calculations on the fly, any attempt to use a complex graphic or a traced image will result in 
very slow animations that chug along and will not be acceptable. Text can also be morphed 
one word can dynamically change into another – here is how you do it.  
 
 
1. With Flash open if you do not have a new blank movie select File>New 

 
2. Select the a drawing tool and create a box in the uppler left corner of your movie it can be 

filled with any color your like.  
 

3. Place your pointer on Frame 30, right click to activate the pop down menu and 
select>Insert Keyframe then hit the delete key on your keyboard to delete the object from 
frame 30.  

 
4. Select the circle drawing tool and draw a circle in the lower left corner of your screen. I 

suggest you fill the circle using the paint can a different color from your box – but it is not 
necessary. You should now have a square or rectangle in our first keyframe and a circle 
in your last keyframe. Place your mouse pointer on the first keyframe to select it.  

 
 

 
 
5. In the bottom of your window in the properties box you will see a Tween drop down 

menu> from the drop down menu select Shape  Tween. You will see a solid line in layer 
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one with a green background. Use the controller to play the movie and you should see 
the square change gradually into the circle – Neat! 

 

 
 

Square morphs into a circle. If you add additional object to the last keyframe the square will 
simultaneously morph into all of the objects – Try it. The main difference between motion tweens 
and shape tweens is that in the former you must convert the object you draw into symbols. With 
shape tweening you do not.  
 
 
If you want to save the movie and embed it into an HTML page run through the steps to save and 
publish it – then center the movie manually by adding <center></center> tags.  
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4. Shape Tweening Text 

 
 Tweening text is similar but there are a couple of extra steps. By default adding text to a flash 
movie converts the text automatically to a symbol – therefore we have to break the symbol apart 
into an object before we can shape tween the text. In this exercise we will tween your name into 
other text.  
 
 

1. Open Flash and start a new movie File>New 
 

2. Select the Font tool in the menu “A” and select a font color from the colors options at the 
bottom of the tool palette.  

 
3. Click your pointer (mouse) on the movie stage. When you do this you will see a text entry 

box or cursor. If you look a the properties box at the bottom of your movie you will see the 
various text attributes including font size, color, format etc. You will want to set your font 
size fairly big for this tutorial e.g. 60 pts – use the slider or type in 60 beside the font type 
box.  

 

 
 
 
 

4. Type your name onto the movie stage e.g. Fred Flinstone. You will see a blue bounding 
box around the message which means it is a symbol. We can’t shape tween symbols so 
we have to break it apart into an object. Click on the text so the blue bounding box is 
visible around it and then select Modify>breakapart, do it again – you need to do it twice 
you should see small poka dots on the text when you are finished – indicating the text is 
now an object,  

 
5. Select Frame 30 in layer 1, righ click and from the pop down menu select>insert 

keyframe then hit the delete key on your keyboard to erase the text from the last 
keyframe.  

 
6. Use your type tool and type a new name or message onto the screen about the same 

font size, it can be a different color if you like. You may wish to move your text, select the 
black pointer from the toolbar then click and drag over the text to move it.  

 
7. You then need to break the text apart again select 

Modify>breakapart>Modify>breakapart  - you need to do it 2X. Then place your pointer 
on the first keyframe of layer one. From the properties box at the bottom select 
Tween>Shape – you should see a solid line with an arrow pointing to the right in layer 
one and the background should turn a lime green color. Use the controller to play your 
mvoie and watch your text morph!   
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5. Making an object Fade in and out and resize movie into a banner. 
 
Flash is a popular tool used to make text or pictures fade in and out and is used for delivering text 
or pictures. We will create a banner 550 x 80 pixels in size with a black background color and we 
will make a message fade in and out. Some folks may decide to use only part of the movie and 
just have the image or text fade in and then stop.  You will need to add a stop action to the end of 
the movie otherwise your movie will loop continuously. 
 
 

1. File >New>Modify>Document – this will bring up a new window from which you can 
resize your movies and modify the background color.  Note you should always decide on 
our movie size first – it can be difficult to change the size afterwards as some of your 
components may no longer be in the movie.  Always leave the movie frame rate at 12 fps 
for animation used on the web – it can be increased to 30 for CD based animations only.  

 

 
 

2. Set the background color to black and the movie dimensions to 550 px x 80 px to create 
a banner. Select>OK  You should see a narrow banner in your window use the scroll 
bars if the movie is not readily visible.  

 
3. Select the Text tool and se the color or your text to white, choose a large font size 

approx. 60 pts. And type the workd “WELCOME”. Click on the text so it shows a blue 
bounding box. Select>Insert>Convert to symbol>Graphic 

 
4. In layer one Select Frame 20 >right click>insert keyframe, select frame 40 right 

click>insert keyframe and select frame 60 >right click insert keyframe. You need multiple 
keyframes because you are going to make the text fade in from frame 1-20, hold between 
20 and 40, then fade out from 40 to 60. To do this you will need to motion tween the 
frames from 1-20, 20-40 and 40-60.  

 
5. Place your pointer on frame one in layer one. Select>Insert>Create Motion Tween, place 

your pointer on frame 20 and repeat, then frame 40 and repeat until all sections of your 
movie are tweened see picture below.  

 
 

6. If you play your movie now nothing happens – you need to make the text transparent at 
the beginning and end of the movie – transparency is referred to alpha – alpha 0 is 
completely transparent and alpha of 100 is completely visible. You will need to set alpha 
property to 0 in the first keyframe and the last keyframe. Select the first keyframe and in 
the properties box select the Color drop down menu select alpha and set it by moving the 
slider to 0. The select the last keyframe and do the same thing. Now play your movie and 
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you should see the text fade in, hold, then fade out. You can do the same thing with 
photos you import into flash. To add additional text you will need to add more layers.  

 
 

 
 

Movie has been tweened – use the Color drop down menu to select alpha and set value to 0 or 
transparent in the first and last keyframe of your banner movie.  

 
7. Save your movie, publish the movie then view your banner by loading the HTML page. 

Note that the movie loops continuously – add a stop action to the last keyframe and 
resave. You will also have to center the banner using <center></center> tags. Notice that 
Flash will automatically set your web page to the same background color you chose in 
your flash movie.  

 
 
 
Exercise: Repeat this but import a small graphic file, convert it to a symbol, then make it fade in 
and out. If you wish to have multiple text messages or photographs you will need to add a layer 
for each additional text message or photo you import – you can have only one animation per 
layer, but there is not limit as to how many layers you can add! 


