
Flash CS3 Basics Tutorials by R. Berdan  
 
Flash Tutorial                   Last Updated June 17, 2008 R. Berdan  
 
Before attempting this tutorial you should be familiar with the tools and flash layout and  
how to start Flash in order create a new movie – initially select action script version 2.0.  
 

1. Select the oval tool from the tool menu and draw a circle in the upper left part of the stage 
and the fill the circle with a solid color (select fill color using the paint bucket).  

 
2. Select the black pointer from the tool bar (selection tool), click and drag around the circle 

you drew on the stage. When you finish, the circle will appear to have small tiny dots – 
this indicates you have selected the object. (if you click off or outside of the object you will 
have to reselect it – look for the tiny dots to tell you the object is selected)  

 

 
 

Circle on the left is selected the one on the right is not.  
 
 
3. With the circle still selected Select>Modify>Convert to symbol>Graphic OK. It is optional 

whether or not you want to name the object. You just converted the object into a symbol.  
You must always do this before you can animate an object you draw across the stage. 
The object should now have a blue bounding box around it – this indicates it is a symbol. 
(Note if you select an oval primitive –you do not need to convert the object to a symbol)  

 
 

4. Select the black pointer from the tool bar and click on the Layer 1 frame box 30 to select 
it – the frame will turn black. Right click on the frame with your mouse and select 
insert>Keyframe. Keyframes are places where an object starts, stops or changes 
direction in a movie.  
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5. Next with the new keyframe you created still selected, click on the circular object and 
move it across the stage to a new location where you want it to stop in the animated 
movie. Then select the first keyframe in layer 1. Go to the properties box at the bottom, 
select Tween drop down menu and select>Motion. Layer should have a solid line with an 
arrow on the end and the layer should turn blue. If you see a dotted line you missed a 
step or possibly did not add a keyframe.   

 

 
  

Note solid blue line in layer 1.  
 
6. To play your movie, first make sure your controller is displayed Select 

Window>Toolbars>controller – select the play button to start your movie. Your object 
should move across the screen and stop.  

 
 

7. To save your movie select File>save as provide a name e.g. firstmovie.fla and direct it 
to folder or your desktop.  This movie can be edited and modified at any time by selecting 
File>open. The .fla file is used for editing it does not go into your web site it is used to edit 
and modify your movie only. Always keep this file in case you need to modify the movie in 
the future.  

 
 
8. To create a movie that can be inserted into a web page you need to have your .fla file 

open in Flash Select>File>Publish settings>check  Flash .swf checkbox and HTML .html 
check box>Then select Publish>OK  - you just created an HTML page with Flash movie 
embedded.  Embedded Flash movies have the extension .swf sometimes called 
shockwave files – these are compressed versions of the .fla files.  To see your movie 
play click on or load the html file you created into a web browser that has the Flash plugin 
installed.  You should see your movie embedded inside the page and the movie will loop 
continuously.  In spite of years of development, Macromedia has never fixed a small bug 
– that is the movie you embedded will not be centered even though there are publishing 
options to do so – they have never worked. To center your movie select >View source 
when previewing it in Internet explorer and add the <center></center> tags manually as 
shown below.  Alternatively you can open the page in Dreamweaver and use the center 
align commands, you can insert the movie into other pages using copy paste of the code 
or you can use Dreamweaver to insert the .swf files – the .swf files must be in the same 
place your web pages are! 

 
<center> 
<OBJECT classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" 
codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version
=6,0,0,0" 
 WIDTH="550" HEIGHT="400" id="Untitled-2" ALIGN=""> 
 <PARAM NAME=movie VALUE="Untitled-2.swf"> <PARAM NAME=quality VALUE=high> 
<PARAM NAME=bgcolor VALUE=#FFFFFF> <EMBED src="Untitled-2.swf" quality=high 
bgcolor=#FFFFFF  WIDTH="550" HEIGHT="400" NAME="Untitled-2" ALIGN="" 
 TYPE="application/x-shockwave-flash" 
PLUGINSPAGE="http://www.macromedia.com/go/getflashplayer"></EMBED> 
</OBJECT> 
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</center>  
 
9. To have the animation play only once you must add an action to the last keyframe. 

Actions are small scripts that provide instructions such as stop, jump to frame, play, 
rewind etc. adding actionscript is one way to add interanctivity to your flash movie.  

 
10. To add a stop action to the movie we created you will need to select the black 

pointer>Select the last keyframe in the movie. Select and open the actions Frame 
(Window>Development Panels>actions or F9) – see below. If you started your movie 
using actionscript version  3.0 – simply type stop();  in the right window.  

 
11.  

 
 
 

10. To insert an action you can do it two way 1) In the main window type stop();  or 2) Click on the 
movie control folder on the left side of the window it will open to reveal different actions.  I.e. 
Global Functions>Timeline Control>Stop(). Double click or drag the stop action into the main 
window  - then close it.  You will see a small “a” in the last keyframe – this tells the movie to stop 
when it reaches this point.  Save your movie – then publish it again.  If you unselect the HTML 
checkbox you will not overwrite the HTML page only the .swf file  - if you do overwrite the HTML 
file you will simply need to add the <center></center> tags again. You are done!   
 

12. One other option you might want to know about is that you can save .fla files as .exe files 
– movies that will play bythemselves without embedding inside an HTML page.  These 
type of movies are used in multimedia presentations, games, business card CDs. They 
are standalone programs that you can e-mail or take with you. To publish a standalone 
Flash movie make sure your previous movie is open select >File>Publish settings>format 
tab should be selected select>Windows projector or Macintosch projector if you want 
your movie to play standalone on a Mac computer. Select Publish>OK and you will see a 
new icon where you saved your files – click on the icon to start your stand alone movie 
program.  
 

  The top icon is a  .swf file and the bottom icon shows a stand alone .exe file.  
 

A. Exercise and practice. Make your circle go completely around the stage so it goes to 
each corner. To do this you will need to add additional keyframes and motion tween 
between each one.  The distance between keyframes determines how fast your object 
moves – keyframes close together will result in faster animation, further apart will result in 
slower animations. When finished add and animate another object on another layer.  

 
B.    Modify the movie so that when it reaches the end it will jump to another web site or web 

page. Hint: you need to use action getURL(http://www.site.com);  
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2. Motion along a specified Path 

 
You can use the animation you created in the previous tutorial or you can start from scratch 
with a new object – either way you must have a moving object to start this tutorial. We are 
going to add a new layer called a motion layer, then we will draw a smooth line that does not 
overlap to simulate a bouncing ball. We will attach the ball or object to the line at the 
beginning and ending keygrame and play our movie – it you do this correctly the ball will 
bounce. It can be a bit tricky attaching the object to the line so persevere.  
 
 
1. Right click your mouse pointer on Layer one> In the pop down menu select Motion Guide 

layer then click on this layer to select it. Only the motion guide layer should be selected. 
 

2. Select the pencil tool and the bottom of the tool box select Option>smooth from the pop 
out menu. Draw a line resembling the bounce path of a ball – see picture below.  

 

 
 
 

3. The object (circle) may jump and attach itself to the line – if it does great, if it does not 
drag the object by its center over the beginning of the line until it snaps in place. If it does 
not snap in place make sure the magnet button at the top (snap tool) is depressed. 
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Then select the last key frame of the movie with the black arrow you should see 
something like the picture below.  

 

 
 
 

4. Move the circle with your mouse (black arrowhead selected in the toolbar) until it snaps to 
the line near the end of your drawing.  Go to the controller (below) and play your movie. 

 

 
 

 
The ball should follow the line and appear to bounce. Make sure the lines you draw do not 
touch each other or cross over each other – it will not work. Save and publish your movie.  
The lines you drew will not appear in the final movie, however the object will appear to follow 
them.  
 
Exercise 1: To make the bouncing ball more realistic add three keyframes where the ball 
touches the ground. In the keyframes – modify the shape of the ball so it appears that the ball 
is being squished when it contacts the ground – you will need to break apart the image, 
modify its height in the properties box,  then convert it back to a symbol. Finally import a short 
“ball bounce sound i.e. bounce.wav” to your library and drag the sound onto the movie in a 
keyframe where the ball touches the bottom. See the demo version. Exercise 2 -  make 
moon circle the earth use photos, trace bitmap command – see demo.  
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3. Shape Tweening also called Morphing  
 
Using flash it is possible to create objects then animate them by morphing one object into 
another.  Generally this works well only with simple objects because Flash has to do all the 
calculations on the fly, any attempt to use a complex graphic or a traced image will result in 
very slow animations that chug along and will not be acceptable. Text can also be morphed 
one word can dynamically change into another – here is how you do it.  
 
 
1. With Flash open if you do not have a new blank movie select File>New Flash Document 

 
2. Select the a drawing tool and create a box in the upper left corner of your movie it can be 

filled with any color your like.  
 

3. Place your pointer on Frame 30, right click to activate the pop down menu and 
select>Insert Keyframe then hit the delete key on your keyboard to delete the object from 
frame 30.  

 
4. Select the circle drawing tool and draw a circle in the lower left corner of your screen. I 

suggest you fill the circle using the paint can a different color from your box – but it is not 
necessary. You should now have a square or rectangle in our first keyframe and a circle 
in your last keyframe. Place your mouse pointer on the first keyframe to select it.  
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5. In the bottom of your window in the properties box you will see a Tween drop down 
menu> from the drop down menu select >Shape Tween. You will see a solid line in layer 
one with a green background. Use the controller to play the movie and you should see 
the square change gradually into the circle – Neat! 

 

 
 

Square morphs into a circle. If you add additional object to the last keyframe the square will 
simultaneously morph into all of the objects – Try it. The main difference between motion tweens 
and shape tweens is that in the former you must convert the object you draw into symbols. With 
shape tweening you do not.  
 
 
If you want to save the movie and embed it into an HTML page run through the steps to save and 
publish it – then center the movie manually by adding <center></center> tags.  
 
You can make an object morph into more then one object – try it.  
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4. Shape Tweening Text 
 
 Tweening text is similar but there are a couple of extra steps. By default adding text to a flash 
movie converts the text automatically to a symbol – therefore we have to break the symbol apart 
into an object before we can shape tween the text. In this exercise we will tween your name into 
other text.  
 

1. Open Flash and start a new movie File>New 
 

2. Select the Font tool in the menu “A” and select a font color from the colors options at the 
bottom of the tool palette.  

 
3. Click your pointer (mouse) on the movie stage. When you do this you will see a text entry 

box or cursor. If you look a the properties box at the bottom of your movie you will see the 
various text attributes including font size, color, format etc. You will want to set your font 
size fairly big for this tutorial e.g. 60 pts – use the slider or type in 60 beside the font type 
box.  

 

 
 
 
 

4. Type your name onto the movie stage e.g. Fred Flinstone. You will see a blue bounding 
box around the message which means it is a symbol. We can’t shape tween symbols so 
we have to break it apart into an object. Click on the text so the blue bounding box is 
visible around it and then select Modify>breakapart, do it again – you need to do it twice 
you should see small poka dots on the text when you are finished – indicating the text is 
now an object,  

 
5. Select Frame 30 in layer 1, righ click and from the pop down menu select>insert 

keyframe then hit the delete key on your keyboard to erase the text from the last 
keyframe.  

 
6. Use your type tool and type a new name or message onto the screen about the same 

font size, it can be a different color if you like. You may wish to move your text, select the 
black pointer from the toolbar then click and drag over the text to move it.  

 
7. You then need to break the text apart again select 

Modify>breakapart>Modify>breakapart  - you need to do it 2X. Then place your pointer 
on the first keyframe of layer one. From the properties box at the bottom select 
Tween>Shape – you should see a solid line with an arrow pointing to the right in layer 
one and the background should turn a lime green color. Use the controller to play your 
mvoie and watch your text morph!   

 
 
 
Exercise: Create an animated banner where you combine movement and a shape tween. Note 
you will need to use separate layers for each type of animation.  
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5. Making an object Fade in and out and resize movie into a banner. 
 
Flash is a popular tool used to make text or pictures fade in and out and is used for delivering text 
or pictures. We will create a banner 550 x 80 pixels in size with a black background color and we 
will make a message fade in and out. Some folks may decide to use only part of the movie and 
just have the image or text fade in and then stop.  You will need to add a stop action to the end of 
the movie otherwise your movie will loop continuously. 
 
 

1. File >New>Modify>Document – this will bring up a new window from which you can 
resize your movies and modify the background color.  Note you should always decide on 
our movie size first – it can be difficult to change the size afterwards as some of your 
components may no longer be in the movie.  Always leave the movie frame rate at 12 fps 
for animation used on the web – it can be increased to 30 for CD based animations only.  

 

 
 

2. Set the background color to black and the movie dimensions to 550 px x 80 px to create 
a banner. Select>OK  You should see a narrow banner in your window use the scroll 
bars if the movie is not readily visible.  

 
3. Select the Text tool and set the color or your text to white, choose a large font size 

approx. 60 pts. And type the word “WELCOME”. Click on the text so it shows a blue 
bounding box. Select>Insert>Convert to symbol>Graphic 

 
4. In layer one Select Frame 20 >right click>insert keyframe, select frame 40 right 

click>insert keyframe and select frame 60 >right click insert keyframe. You need multiple 
keyframes because you are going to make the text fade in from frame 1-20, hold between 
20 and 40, then fade out from 40 to 60. To do this you will need to motion tween the 
frames from 1-20, 20-40 and 40-60.  

 
5. Place your pointer on frame one in layer one. Select>Insert>Create Motion Tween, place 

your pointer on frame 20 and repeat, then frame 40 and repeat until all sections of your 
movie are tweened see picture below.  

 
6. If you play your movie now nothing happens – you need to make the text transparent at 

the beginning and end of the movie – transparency is referred to alpha – alpha 0 is 
completely transparent and alpha of 100 is completely visible. You will need to set alpha 
property to 0 in the first keyframe and the last keyframe. Select the first keyframe and in 
the properties box select the Color drop down menu select alpha and set it by moving the 
slider to 0. The select the last keyframe and do the same thing. Now play your movie and 
you should see the text fade in, hold, then fade out. You can do the same thing with 
photos you import into flash. To add additional text you will need to add more layers.  
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Movie has been tweened – use the Color drop down menu to select alpha and set value to 0 or 
transparent in the first and last keyframe of your banner movie.  

 
7. Save your movie, publish the movie then view your banner by loading the HTML page. 

Note that the movie loops continuously – add a stop action to the last keyframe and 
resave. You will also have to center the banner using <center></center> tags. Notice that 
Flash will automatically set your web page to the same background color you chose in 
your flash movie.  

 
8. Unless you want your movie to loop continuously, you will need to go back add a stop 

action or a getURL action.  
 
 
 
Exercise: Repeat this but import a small graphic file, convert it to a symbol, then make it fade in 
and out. If you wish to have multiple text messages or photographs you will need to add a layer 
for each additional text message or photo you import and you will have to stagger the movies so 
one starts after the other finnishes – you can have only one animation per layer, but there is not 
limit as to how many layers you can add! 
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Creating & Using Simple Buttons in Flash MX 2004 
 
You can add built in buttons to any movie to control the timeline such as PLAY, STOP and 
REWIND by adding buttons from the common library and attaching actions to them. When ever 
you add buttons you should always create a new layer first and put the buttons on this layer. 
Drag several buttons onto the stage then add actions to them – in order to add play(), stop() etc 
you will first need to add Global Functions>Movie clip control>On  then an event handler like 
press() or release() – then add play() stop() actions. E.g.  
 
on (press) { 
 play();  
} 
 
 
Flash also allows users to create any shape of button and can even create animated buttons. 
Buttons can be used to play, stop, start, goto a specific frame, scene in a movie or jump to 
another web page. Buttons can also be used to submit forms, load images or activate action 
script programs for example to calculate numbers.  
 
In order to do this tutorial you will need to have a simple movie with some animation first.  For 
example you could use a ball moving across the stage or some other animation you made.  We 
will create and add a simple PLAY, STOP and REWIND BUTTONs with rollover effects.  
 
 

1. Start Flash and open an existing animation or make a simple movie (see previous 
tutorials).  Make a ball move across the screen if you do not have a movie.  

 
2. Select the top most layer with the black arrow head from the tool box and right click – 

select insert layer. Label this layer buttons. Buttons should be placed on their own 
separate layer.  

 
 

 
  

3. Select the Buttons layer, then select the rectangle drawing tool in the tool palette  
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In the options at the bottom of the tool palette click on the “curve button”.  
 

 
 
Enter a value of 5 for the curve radius. This permits you to add corners to the button. You can 
experiment with the values of the curve radius.   Select a color you want your button to be 
(paint can color selector in the tool box).  
 
I am going to select gray with a black pencil stroke of 4 pixels.  
 
4. Select the Type tool and a text color – then type the word PLAY on top of the button you 

made.  Use the black arrow head to position the text on the button .  
 

 
 

Here is my button – black text on a gray background with a black stroke of 4.  
 
 

5. Next – select the black arrow head and drag a selection around the entire button so that 
the button is selected so we can convert it to a symbol.  Select >Insert>Convert to 
Symbol>button  in the top menu. Next we need to change the colors in the button in the 
different rollover states.  

 
6. Place the black arrow head on the button and right click, from the pop up menu select 

>Edit  -  see screen shot below. You are now in button editing mode.  
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7. First you need to add a keyframe in layer 1 to all 4 button states. Place your black arrow 
head in layer on in the frame Over – right click>add Keyframe, Repeat this in the Down 
and Hit frames. Up is the appearance of the button when the page loads, Over is the 
state of the button when a user places their cursor over the button, down is the state of 
the button when the user presses their mouse down and hit defines the area of the button 
that responds to the users mouse click.  

 
 

8. Once you have added all the keyframes, select the OVER keyframe, then click on the 
background color of your button. Select a new color from in the tool palette (paint can) 
and you will see the background color of the button change. Be careful not to include the 
text in your selection or it will also change color.  

 
 

 
 

9. Repeat this for the  Down State – add keyframe, change the background color. If you 
move the red playhead the button should change color when move it from one frame to 
the other.  

 13



 
10. Return to the main movie stage – to do this – click on the left pointing blue arrow under 

the layers. (or you can select Edit>Edit document from the menus).  You should be 
returned to the main movie. Now you are ready to test the rollover effect.   Select> 
Control>Enable simple buttons  - move your cursor over the button and it should display 
the rollover effect.   Then select>Control>Enable buttons again to unselect the buttom 
test mode. To make this button do something we need to add some action script. 

 
11. First we need to add a stop action to the first keyframe of the movie – this is so the movie 

does not start playing byitself which is the default. Place your cursor (black arrow head) 
in the first keyframe of layer one of your movie. Right click, from the drop down menu 
select>actions>Movie control and drag the stop action into the main window then 
collapse the action script window. You should see an “a” in the first keyframe.  

 

 
 
 

12. Now we need to add an action to the Button we created. Right click on the button, select 
actions from the pop up menu. Then select from the movie control folder> on (press) { }, 
then select play() so you see the code 

 
on (press) { 
 play(); 
} 
 
collapse the action script window.  
 
13.  Select Control>Test Movie – click on the button and if you did everything right the ball will 
move across the screen and then return to its starting position.  
 

 14



  
 
 

13. To add 2 more buttons one to STOP and another to rewind the movie – repeat the steps 
you did to make the PLAY button but add the actions 

 
on (press) { 
stop(); 
} 
 
and to the last button to rewind 
 
on (press) { 
gotoAndStop(1); 
} 
 
 
These are the basic steps to creating custom buttons. If you want to animate you buttons you can 
add an animation to the OVER or DOWN states. The animation can be a separate movie clip. 
You can also add sound effects to the buttons, but to do this you must either import the sound or 
use a built in sound from the library. The sounds are inserted into one of the keyframes of the 
button in edit mode.  
 
 
In conclusion these tutorials are aimed at getting anyone started in Flash and although they may 
seem simple these basic actions can permit you to make some sophisticated animations. 
Creating animation can be time consuming so it is strongly advised that before you attempt to 
make a complex animation that you create a series of sketches or a plan which we call a 
storyboard. This will help you plan your movie, save you time and if preparing movies for a client 
it can save you both time and money. For more tutorials check out Flashkit.com on the web or 
many other web sites e.g. www.scienceandart.org.  
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Movies within Movies 
In flash it is possible to put a movie within a move. The easiest way to do to this is to make a 
movie clip, import a gif animation, then place the animation into your timeline – animate it. You 
will need to prview the movie (Control>Test movie) to see the animated movie.  
 
1. First find a gif animation on the web e.g. a butterfly or bat and save it into a folder.  
 
2. Start Flash and a new movie 
 
3. Select Insert>New Symbol and you will be in movie clip editing mode. This is separate from the 
main time line. You can create your own animation in here or to simply things lets import the 
animated.gif file bat or butterfly.  
 
4. Select File>import to stage – you should see your bat or butterfly and a series of frames at the 
top. Gif animations use frame by frame animation the number of frame can vary.  
 

 
 
5. To return to the main movie time line, click on the left side over the blue arrow pointing left or 
select Edit>Edit document (Ctrl-E).  
 
6. In the libraray panel, select Symbol 1 (assuming you did not name the movie clip) and drag it 
onto the stage and save your movie e.g. batmovie.fla.  
 
7. To preview your movie select Control>test movie – you should see your bat or butterfly flying in 
place. To move your animal across the screen, insert a new keyframe e.g. at 30. Move your 
animal to a new position on the stage. Go back and select the first keyframe in the time line and 
from the properties box select – motion tween. Select Control>test movie to see you animal flap 
its wings and fly across the screen.  
 
8. To make the flight look more realistic – create a motion guide layer and attach your animal to 
the guide. Modify the background as you see fit, add play and stop buttons to control the movie.  
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