
Using Masks in Flash CS3  by R. Berdan 
 
Masks are “holes” or “windows” that reveal content in layers below. Masks can be used to reveal 
things gradually like text or make objects appear to “write” themselves. Masks can also be used 
to simulate magnified views or create special effects.  
 
Exercises 
 
1. Simple wipe mask 
2. Spot light mask  
3. Soft Edge Mask 
4. Make an object appear to draw itself by selectively revealing parts with two masks.  
5. Make a magnifying glass that enlarges area below 
6. Make draggable objects using actions script  
7. Insert a photo – into a draggable magnifying glass movie – reverse engineering  
 
Simple Banner that reveals text gradually from left to right  
 
 
1. Open flash and create a new movie. Set the dimensions of the movie to 550 x 100 for a banner 
and select a dark background color.  
 
2. Type a message on the banner e.g. Science & Art Multimedia, use 40 pt font, color white.  
 
3. Create a new layer – call it Mask layer and with this layer selected use the rectangle tool to 
draw a rectangle large enough to cover your banner make sure it has a solid color fill, no stroke – 
I use red but any color will work fine. Position the rectangle off the movie and to the left of the 
stage.  
 
4. Select the rectangle and select Modify>Convert to Symbol 
 
5. Insert a keyframe in frame 30 in both the bottom and top layers, then select the first keyframe 
in each layer and from the properties box select motion tween.  
 
6. Move the rectangle in the 2nd (top) layer over top of the banner text so it is completely covering 
it.  
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7. Select the top layer, right click on it and select Mask. Play your animation and you should see 
the text gradually appear from left to right as the mask gradually covers it. (Unselect the mask 
option after right clicking on the top layer to turn the mask off and modify the shape and size of 
the mask object). To make the mask stop add action script stop() action to the last keyframe.  
 
The mask can be made to reveal from top to bottom, or left to right. The main thing to understand 
is that as the mask covers the picture below it – it reveals what is underneath – you are creating a 
window to see what is below.  
 
 
Spot Light Mask  
 
1. Create a new banner similar to the one above or you can delete the mask layer in the 
animation above. 
 
2.  Create a new layer and draw a circle with a diameter slightly larger then the height of the 
banner and place it to the left of the banner  - if you use the object oval, you will need to convert it 
to a symbol. If you draw an oval primitive – you can eliminate the convert to symbol step.  
 
3. Create a keyframe at 30 in the second layer, move the circle to the right over the banner.  
Select the first keyframe in layer 2, and from the properties box select motion tween. Play the 
movie and the circle should move over top of the banner.  
 
4. Right click on the 2nd layer and convert this layer to a mask. Play the animation and you will 
see a moving hole over your banner selectively revealing the text below.  
 

 
 

 
 Mask turned on – text is visible only below the moving circle in mask mode, above mask mode is 
off so you can see the position and size of the circular mask.  
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How to create a softe edge “mask” 
 
Unfortunately in the previous examples if you fill the circle with a gradient, even one with one of 
the colors being transparent or converting to a movie clip and blurring  the edges when you 
convert these to a mask layer Flash treats the entire object as a mask with hard edges. To 
simularte a soft mask you will need to create movie clip with a hole in it – blurr it to reveal the 
contens below.  
 
 
1. The way to do it is to create a second layer – draw a rectangle twice as wide and slightly taller 
then the current banner. Draw a circle in the middle of this new large banner – use a different 
color. Make sure you are not in merge mode, not object mode. Then cut or drag the circle out of 
the banner to make a hole.   
 
2. Convert this new rectangle with hole in it to a movie clip.  
 
3. Select Filters>blur> select a blurr value of 20-30 to create soft edges.  
 
4. Position of the movie clip overtop of the banner at the start of the text – “Science & Art” then 
create another keyframe at 30. Move the hole to the end of the text and tween the movie clip. 
Play and you should see the text through a soft hole.  
 

 
 
In this screen shot I moved the movie clip above the banner so you can see the entire “mask”, 
move it down over top of the banner and animate it from left to right. The text will appear through 
the hole. You do not convert the 2nd layer to a mask layer.  
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Using Masks so an object appears to Draw Itself - by R. Berdan  

This example shows how to take rather simple object, an oval, and by using masks make the 
object appear to draw itself. You can use this technique will almost any object though more 
complex drawings will require more layers and may require a variety of different shapped masks 
(e.g. Lifeform chair example) 

1. Start Flash and create a new movie and turn the rulers on.   

2. In merge mode (not object mode) select a basic oval tool. Set the stroke to red, stroke width 4 
pixels, and the oval with no fill color 

3. Name the first layer bottom of circle. Draw a large oval on the screen and drag a guide line 
from the top ruler. Select frame 30 in the time line and add a blank keyframe.  

 

4. Create a new layer above this layer and call it top of circle, create a keyframe in this time 
line at frame 15  Use the selection tool to outline the top of oval in layer 1 to select it – then 
select Edit>Cut to copy the top of the circle into the computer’s memory. Paste the top into 
the second layer, keyframe 15.  We need to split the circle into two pieces in order to make 
two separate moving masks.  

5. Create a new layer above the bottom of circle layer.  Create a solid filled rectangle with no 
stroke that is just large enough to cover the bottom of the circle and place it on the left of the 
circle. Covert this rectangle to a symbol, insert a keyframe in the time line at 15. Move the 
rectangle so it covers the entire bottom of the circle – but not the top half. Select the first 
keyframe in this layer and add a motion tween. The rectangular box should move over the 
bottom of the circle. If you select this layer and change it to a mask and scrub the playhead 
you will see the circle gradually appear from left to right.  

6. Create a new layer above the top circle and name it top mask. From the common library 
panel drag the previously created rectangular symbol into keyframe 15 in the top layer. 
Position this rectangle just to the right of the top half of the circle.  Create a keyframe at 30 in 
the top layer and move the rectangle so it covers the top half of the circle. Select the 
keyframe 15 and from the properties box select motion tween so the box moves from left to 
right and covers the box. Right click on the top mask layer and covert it to a mask – and play 
your movie. The circle should appear to draw itself from left to right in the bottom half, then 
from right to left in the top half. Your movie should like the screen shot below (mask mode 
turned off so you can preview the rectangles when the playhead is at frame 15 in the timeline.  
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Convert layer 2 and 4 to masks and play and the circle will appear to draw itself from left to right 
and then right to left.  
 
 
 
Use a Mask to Magnify and image or Text  
 
In this tutorial you will put in some small text “Magnify”, then in a layer above it you put in the 
same text but much larger. You will create a circle, convert it to a mask and animate it across the 
screen. The area under the circle will be magnified. You will then draw a magnifying glass and 
synchronize its movement to the circle. 
 
 
1. Create a new movie in Flash, size the document to 550 x 250 pixels 
 
2. Type the wods “Magnify Text” in black, font size 72 pt, Times New Roman and center. Label 
the layer normal text.   
 
3. Create a new layer called enlarged text. Type the same text “Magnify Text” in Black, font size 
96 and place it directly overtop of your original text.  
 
4. Create a new layer above and call it glass mask. Draw solid filled circle about, the diameter 
about the same size as the largest M i.e. 96 pts and place it on top of the large Letter M. Select it 
and Modify>Convert to symbol. Create a keyframe at 30 in all three layers. Then move the circle 
to the right of the words so its on the last letter T of text.   
 
5. Create another layer above the normal text, create a circle the same size as the one used in 
the magnifying glass, you can drag an instance of the circle symbol on to the screen – select 
Color>Tint in the properties box and make the circle white in color. Place it in the same spot as 
the top circle used in the mask, create a keyframe at 30 and move it to the same place as the top 
circle at the end of the animation. This blocks the small text view when the mask is over top.  
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6. Draw a magnifying glass – make it look like its made of shinny metal. Here is one way. First 
create a new layer call it magnifying glass.  
 
Drag an instance of the circle onto the left of the movie clip. Then drag a new circle overtop make 
it slightly larger and use a linear gradient white to black to give it a metallic look. .  
 

  
 
 

 
 
Then covert the red symbol into an object by Selecting Modify>Breakapart. Drag the circle off the 
larger circle to get a cookie cutter metal frame for your magnifying glass.  
 

                                  
 
Create a gradient black, to white, to black as shown above. Create a small rectangle and fill with 
this gradient. This will form the next of the magnifying glass handle.  
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Now select another color like blue or green and create a similar gradient blue to white to blue and 
make a longer handle include a black stroke. Once you have the neck and handle use the free 
transform tool to rotate the neck and handle and use the arrow keys to position them next to the 
magnifying glass. Once this is done select all the objects in the magnifying glass and 
Select>Modify>Groiup to group them together.  
 

 
 
Now move the glass into position so it covers the top of the circle used for the mask, conver the 
glass to a symbol and animate it so it follows the circle exactly.  
 
 
You could make the movie go back the other way – and much more. An advanced technique is to 
make the magnifying glass draggable so you folks can move it over a picture and examine it more 
closely.  
 

 
 

Finished movie  
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Making Objects Draggable - Mr Mellon Head 
 
Using some basic action script you can make objects that are draggable on the screen these can 
be used to create puzzles, games or even ask users how they might like arrange certain items.   
 
First we will start with a simple circle and make it draggable, the we will build a puzzle where kids 
can drag various vegetables to make a face.  
 
1. Create a new movie in flash select actions script version 2.0 make the movie a bit taller about 
600 x 400.  
 
2. Draw a circle on the screen and convert it to a movie clip Select the ball, Modify>movie clip 
name it blue_ball 
 
3. Double click on the ball to go into edit mode. Select the ball and convert it to a button 
Modify>Convert to symbol>button. You can only attach scripts to buttons,  movie clips or 
keyframes not graphics.   
 
4. Select the ball and open up the actions tab and type the following script inside.  
 
on (press) { 
  startDrag("");  
} 
on (release) { 
 stopDrag();  
} 
 
 
Then test the movie by selecting – Control test movie. You should be able to drag the ball around 
the screen when you press and move your mouse. Add another red ball on its own layer in the 
main time line. You should be able to move both balls independently.  
 
Any object that is converted to a movie clip, then a button can be made draggable. In this next 
exercise you will make a puzzle – Mr Mellon Man. All of the graphics will be provided. The 
background will be the large mellon, when you are finished drag the pieces on the screen to 
make various faces.  
 
 
1. Create a new movie – select Flash actionscript version 2.0. Save your movie as 
Mr_mellonhead.fla.  
 
2. Import to stage mellon.jpg this will be your background image over which all your other images 
can be dragged over.  
 
3. Create a new layer for each graphic you import, convert each to movie clip, then a button and 
atdd the script above. Import your graphics first to the library, then drag an instance on the stage.  
Note if you have have more then one item e.g. two blueberrys you can simply create a new layer 
and drag an instance of the movie clip onto the new layer and it will be draggable.  Be sure you 
change the  orientation of the some of the fruit before making them draggable. With the lettuce 
you will have to trace bitmap and remove the background. If you want to place blueberries on top 
of peaches – the order of the layers is important.  
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Finished Mr Mellon Head.  
 
To restrict the movement of an object to a specified area you first need to know how Flash uses 
coordinates to position items.  
 

 

 9



Then when you type write the action script for draggable objects you can specify where the object 
can and can not be movied to on the screen.  
 
 
on (press) { 
 startDrag("", true, 148, 155, 455, 343) 
 // target name optional, lockcenter, l, r, t, b) 
} 
on (release){ 
 stopDrag();  
} 
 
 
 
How to modify a symbols registration point.  
 
A registration point is a circle with a cross found on the an object. It is the default location of an 
object from which its x, y coordinates are determined. If you want to rotate an object around its 
registration point sometime you will want to move it.  
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